miércoles, 18 de marzo de 2015

DD-WRT modo Client Bridge (Routed) con Modem CANTV ZTE ZXHN H108N V2.5

Hace poco tiempo intenté conectar el router con dd-wrt utilizando el modo "Client Bridge" con otro router un linksys E1000, y aunque lograba acoplarlos la conexión apenas duraba unos minutos, ni idea porque.

Ahora que se compró un nuevo y flamante "Módem CANTV ZTE ZXHN H108N V2.5" quise probarlo del mismo modo que el linksys, aunque no esperé muy buenos resultados, para mi sorpresa no solo conectó a la primera sino que además parece bastante estable, no se desconectó (la conexión entre módem y router) aunque descargué una archivo por casi dos horas, los parpadeos en la conexión que vi se que son 100% de CANTV.

El router que utilicé fue el ya veterano "TP-Link TL-WR741ND V4" y el "Módem CANTV ZTE ZXHN H108N V2.5", para que todo funcione, la configuración "Wireless" debería ser igual en ambos equipos, vamos a ver ahora la configuración que usé.

La configuración del Módem ZTE:







Recordar que para que funcione correctamente, la configuración de "Wireless" debería ser igual en ambos equipos. Ahora, así va la configuración en el router con dd-wrt:

La versión de dd-wrt:


Accedemos al router, ip (192.168.1.1), y nos movemos hasta la pestaña "Wireless → Basic Settings" y lo modificamos de la siguiente manera:

» Wireless Mode: Client Bridge (Routed).
» Default GW Mode: Auto(DHCP).
» Wireless Network Mode: Igual al módem ZTE.
» Channel Width: Igual al módem ZTE.
» Wireless Network Name (SSID): Igual al módem ZTE, en mi caso (Parrot).
» Network Configuration: Bridged.
» Salvamos sin aplicar los cambios.


Esta parte es opcional, es si queremos que el router funcione como repetidor, es decir, si queremos tener acceso a el mediante WI-FI.

Para eso presionamos el botón "ADD" en "Virtual Interfaces" y lo configuramos de este modo:

» Wireless Mode: AP.
» Wireless Network Mode: Usamos uno diferente, en mi caso (Parrot~)
» Wireless SSID Broadcast: Enable.
» AP Isolation: Disable.
» Network Configuration: Bridged.
» Salvamos sin aplicar los cambios.



Vamos hasta la pestaña "Wireless → Wireless Security" y modificamos:

» Security Mode: Igual al módem ZTE.
» WPA Algorithms: Igual al módem ZTE.
» WPA Shared Key: Igual al módem ZTE.


En Virtual Interfaces:

» Security Mode: Igual al módem ZTE.
» WPA Algorithms: Igual al módem ZTE.
» WPA Shared Key: Igual al módem ZTE.
» Key Renewal Interval: Valor por defecto.
» Salvamos sin aplicar los cambios.



Vamos a la pestaña "Setup → Basic Setup" y modificamos:

» WAN Connection Type: Disabled.
» Local IP Address: 192.168.1.2.
» Subnet Mask: 255.255.255.0.
» Gateway: 192.168.1.1.
» Local DNS: 192.168.1.1.
» Assign WAN Port to Switch:Marcar esto para usar el puerto WAN como otro puerto LAN.
» Salvamos sin aplicar los cambios.



En la pestaña "Setup → Advanced Routing" cambiamos:

» En "Operating Mode" cambiar a "Router".
» Salvamos sin aplicar los cambios.



En la pestaña "Services → Services" cambiamos:

» DNSMasq: Disable.
» Salvamos sin aplicar los cambios.



En la pestaña "Security → Firewall" modificamos:

» Desmarcamos todas las casillas excepto "Filter Multicast".
» Salvamos sin aplicar los cambios.



Y ya esta listo, ahora podemos aplicar los cambios y reiniciar el router.

Para acceder al Módem ZTE sería con la ip (192.168.1.1).

Y para acceder al router con dd-wrt sería con la ip (192.168.1.2).

dd-wrt info:


En esta página encontré la contraseña para entrar al Módem ZTE:
teamhardwarevzla

Y créditos al blog de Pablo que de él seguí las indicaciones:
Blog de Pablo

16 comentarios:

Angel Martinez dijo...

Amigo super agradecido por todas las indicaciones me funciono todo, excelente, te felicito...

Angel Martinez dijo...

Lo único es que mi celular un samsung S4 mini, ni le aparece la red wifi, que sera, como puedo hacer? la laptop y un blackberry si la encuentra...

L.J.Marín dijo...

Hola Angel, me alegra que te sirviera la información, con lo de celular S4 mini es difícil responder esa pregunta, sobre todo si te puedes conectar con otros dispositivos y con ese no,

he tenido problemas parecidos en algunos casos, por ejemplo si colocaba un canal alto en el router, como el 13, algunos celulares BB no encontraban la señal y por lo mismo no podían conectarse, también en otros celulares más antiguos es imposible conectarse con dd-wrt, por ejemplo algunos celulares chinos,

por problemas como esos hay dos router funcionando ahoramismo (: así que no es fácil responder esa pregunta, porque pueden ser varias cosas, puedes revisar la wiki de dd-wrt y comparar los pasos de configuración, en las versión estable puede ser un poco diferente, lo mismo con versiones más nuevas (betas), la wiki en español (http://www.dd-wrt.com/wiki/index.php/Repetidor_Puente),

puedes verificar los pasos y comprobar que tienes la misma configuración en ambos router, que estés creando una nueva interfaz virtual para la red wifi y sobre todo que las contraseñas sean iguales, espero te sirva, saludos.

Administrador GM dijo...

Mil gracias, me funciono de maravilla, solo he notado que pasado cierto tiempo se desconecta sin razon, que podra ser?

L.J.Marín dijo...

Es cierto, en ocasiones después de cierto tiempo como dices se desconecta, sobre todo en los primeros minutos de conexión, no lo noté enseguida pero es verdad,

en mi caso lo que hago es apagar ambos router esperar un par de minutos y prenderlos de nuevo, comienzo con el principal (ZTE), cuando logra establecer la conexión a Internet prendo el router con dd-wrt, la mayoría del tiempo esto me funciona, cuando no funciona repito el proceso,

como observación; en mi caso una ves se establece la conexión entre ambos router y la conexión funciona bien desde el principio, esta se mantiene así, es decir, cuando la conexión se pierde entre los dos router es casi siempre en los primeros minutos, pero si eso no pasa, la conexión se mantiene estable,

otra cosa que también noté es que cuando el router principal (ZTE) coloquialmente hablando se "laguea" ya sea porque la conexión de cantv está muy mala o porque tienes varios equipos conectados a el (ZTE) y estos consumen todo el ancho de banda, cuando eso pasa, la conexión se pierde con el router con dd-wrt y después de eso le cuesta mucho recuperarla,

para no ser injusto, decir nada más que el router utilizado para el ejemplo estuvo a punto de ir a la basura, malísimo con la conexión, se perdía a cada rato y no la recuperaba hasta apagar y prender de nuevo, el que tenga uno igual o parecido lo sabrá,

con dd-wrt eso cambió, si lo utilizo como router normal funciona muy bien, y solo lo he visto perder la conexión cuando la red de cantv está malísima, diferente a eso nunca lo he visto perder la conexión, así que bueno, es lo del pro y contra, creo que hay más pros que contras (:

saludos y gracias por comentar.

Pablo Ariel Nicoli dijo...

Sabes si se puede usar el ZXHN H108N R1A para hacer de social hotspot ?

L.J.Marín dijo...

Hola Pablo,

la verdad no recuerdo haber visto esa opción dentro del router (quizás me equivoque), pero el asunto es que ya no tengo ese router aquí, lo cambiamos por H108L,

saludos.

Ricardo dijo...

Hola L.J. tengo un modem ZTE 108N como el tuyo pero con firmware 2.1 y me gustaría una de dos:
1. conseguir el fimware 2.5 o
2. saber si el firmware de Openwrt funciona bien en el H108n
me refiero a este
https://wiki.openwrt.org/toh/zte/zxhnh108n

Gracias de todos modos

L.J.Marín dijo...

Hola Ricardo,

lo primero, yo alguna ves me instalé a buscar alguna actualización más nueva para el router ZTE y no conseguí nada oficial desde la página de ZTE, instalar algo descargado de otro sitio por lo menos yo no me arriesgaría,

segundo, habría que ver si tienes el mismo hardware que donde se probó openwrt, es decir el mismo chip la ram y todo eso, tampoco vi comentarios en el foro así que saber si funciona bien o no es difícil, ese equipo imagino es más complicado porque manejas dos cosas que es modem y router y no debe haber mucha gente por ahí trabajando en ese firmware,

lo otro es que si lo brickeas como haces para recuperarlo? por ejemplo me pasó con el router tplink, lo pude recuperar y fue más bien fácil, también recupere otro tplink pero con ese tuve que utilizar un cable dku de los nokia viejitos y aunque me costo lo conseguí, y cobre por cierto, pero ese ZTE habría que ver...

si te está funcionando relativamente bien te diría que lo dejaras tal cual, a menos que sepas que si lo brickeas tienes como recuperarlo, en la página de openwrt dicen algo de eso pero es un riesgo y no sabes si va funcionar.

Ricardo dijo...

Excelente tu respuesta!!
Voy a seguir tu consejo y no haré cambios porque ahora tengo algo funcional y cierto es que busqué el modo de resguardar el firmware actual pero no vi cómo hacerlo.
Asi que lo mejor es no complicarse, y dejarlo asi. Buscaré un modem que mejor soportado.

Eduardo Del Nogal dijo...

Amigo excelente publicación, ahora una pregunta importante.

Estableciste la conexión router-router por un medio alámbrico o por un medio inalámbrico.

La pregunta se debe a que debido a que en mi casa tengo el modem ZTE ZXHN H108N y no distribuye wifi a todos los cuartos, he comprado por mercadolibre un router nexxt solution con la función de WDS, pero he leído en algunos foros que el bridge inalámbrico no es posible si uno de los 2 equipos no tiene la función WDS.

Por favor, espero tu pronta respuesta. Saludos

L.J.Marín dijo...

Que tal Eduardo,

la conexión que explico aquí es inalámbrica, y la conexión funciona pero no es estable el 100% del tiempo,

si quiere algo más estable le recomendaría conectarlos por medio de cable y configurar su nuevo router como Access Point.

Eduardo Del Nogal dijo...

Gracias por la respuesta amigo, supongo entonces que el Router raíz en este caso es el ZTE y el otro router con el firmware DD WRT es el repetidor.

L.J.Marín dijo...

Si es correcto, el ZTE será el principal y el nuevo router será el access point,

las instrucciones las puedes ver acá:
https://www.dd-wrt.com/wiki/index.php/Wireless_Access_Point/es

Eduardo Del Nogal dijo...

Amigo saludos!!

Tengo en mi poder el router que te mencioné, con la particularidad de que al final decidí cambiarlo por uno TP-LINK.

La cuestión es que hice la configuración y me va de maravilla, hasta que por mala cuestión se apague el modem-wifi ZTE, se vaya la luz o el internet se ponga tan lento que haya que reiniciar el modem-router raíz.

Cuando esto pasa tengo que configurar todo nuevamente con el router TP-Link que dispuse como repetidor, después de ir a reiniciarlo manualmente ya que una vez configurado como repetidor no puedo entrar nuevamente a la consola de configuración, situación que es bastante tediosa ya que en la zona donde vivo se va la luz al menos 2 veces por semana.

L.J.Marín dijo...

Epale Eduardo!,

hermano me alegra que le funcione la configuración, la parte que no le entiendo es cuando dice que no puede entrar en la configuración del router tplink que tiene "asumo" como repetidor,

si es así debe tener algo mal con la configuración, quizás sea que le está colocando a ambos router la misma dirección ip y claro si es así uno de los dos no le va a funcionar como es,

revise bien que su router repetidor tenga una ip distinta a la de su router principal, es cierto lo que dice que a veces se pone muy lento y hay que reiniciar los router y eso pero de hay a que su router repetidor no se pueda acceder a la configuración es otra historia,

ya sea que lo configure como repetidor a través de cable o de modo inalambrico siempre debería poder acceder al router sin problemas, revise las ip de los router que sean distintas y cuénteme si no es eso, Saludos.